IPv6BBS

 找回密码
 注册

扫一扫,访问微社区

QQ登录

只需一步,快速开始

查看: 4634|回复: 4

NAT-PT不是用来在IPV6或V4网络之间互通的吗,请高手进来帮忙

[复制链接]
菜鸟学徒 发表于 2013-6-22 18:36:39 | 显示全部楼层 |阅读模式
拓扑.jpg
NAT-PT转换表.jpg
V4转换V6.jpg
V4 ping V6.jpg
求各位朋友帮我看一下,V4 ping V6为什么不通,NAT-PT技术不就是让它们可以互通的吗,就是说PC1为什么PING不通PC2。。小弟是菜鸟一名,求大神们帮忙

R4当作PC2:
!         
interface FastEthernet0/1
ip address 192.168.1.4 255.255.255.0
duplex auto
speed auto
!         
ip default-gateway 192.168.1.2
ip classless
ip route 202.12.1.0 255.255.255.0 192.168.1.2
!         
!
  
R3当作PC1:
!         
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2000::2/64
ipv6 nat
!         
ip classless
!         
!         
no ip http server
no ip http secure-server
!         
ipv6 route ::/0 2000::1
!         
!

R1配置:         
!  
!         
!         
interface FastEthernet0/0
ip address 202.12.1.1 255.255.255.0
duplex auto
speed auto
ipv6 nat
!         
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2000::1/64
ipv6 nat
ipv6 rip cisco enable
!         
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!         
router rip
version 2
network 202.12.1.0
no auto-summary
!         
ip classless
!         
!         
no ip http server
no ip http secure-server
!         
ipv6 router rip cisco
  poison-reverse
!         
ipv6 nat v4v6 source 192.168.1.4 2002::1
ipv6 nat v6v4 source 2000::2 202.12.1.3
ipv6 nat prefix 2002::/96
!         
!  


R2配置:
         
!         
interface FastEthernet0/0
ip address 202.12.1.2 255.255.255.0
duplex auto
speed auto
!         
interface FastEthernet0/1
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!         
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!         
router rip
version 2
network 192.168.1.0
network 202.12.1.0
no auto-summary
!         
ip classless
!         
!  
满天星 发表于 2013-6-22 19:51:32 | 显示全部楼层
楼主,你的图都看不到的!
还在折腾实验NAT-PT的配置呢?
建议先搜索、参考论坛的帖子,然后自己分析下你的问题在哪里!
http://www.ipv6bbs.cn/thread-100-1-2.html
http://www.ipv6bbs.cn/thread-96-1-2.html
还搞不定再将你的具体图发上来吧!
 楼主| 菜鸟学徒 发表于 2013-6-22 21:29:49 | 显示全部楼层
满天星 发表于 2013-6-22 19:51
楼主,你的图都看不到的!
还在折腾实验NAT-PT的配置呢?
建议先搜索、参考论坛的帖子,然后自己分析下你的 ...

额不好意思啊,http://xiangce.baidu.com/picture ... 80f687be23f0c52c286
就这里面的那四张图
满天星 发表于 2013-6-23 11:41:44 | 显示全部楼层
说实话,你发的这个帖子我都懒得看,图和文字还得找半天,挨个挨个给你核实,任何地方发帖请有点自己的条理和思路!这是基本常识!
我看了半天,大概发现了几个问题,懒得细看了,图和文字的对应关系以及条理排列和现有的问题描述,实在是找的太费劲!
1.所有Cisco的router,如果需要开启ipv6的转发功能,则要在全局视图下开启:ipv6 unicast-routing
2.R3作为pc1,接口下只需要有ipv6 address,不需要ipv6 nat
3.如果说你的配置还有问题,请尝试去掉R2,精简网络结构,最小化配置和模式运行,自己再排查吧!
 楼主| 菜鸟学徒 发表于 2013-6-23 13:41:32 | 显示全部楼层
满天星 发表于 2013-6-23 11:41
说实话,你发的这个帖子我都懒得看,图和文字还得找半天,挨个挨个给你核实,任何地方发帖请有点自己的条理 ...

谢谢你!!!!!!!
您需要登录后才可以回帖 登录 | 注册

本版积分规则

Archiver|手机版|小黑屋|IPv6BBS ( 京ICP备13024693号 | 京公网安备11010802012238 )

GMT+8, 2020-11-30 19:34 , Processed in 0.020491 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表